{pkgs, ...}: {
extraPlugins = [
(pkgs.vimUtils.buildVimPlugin {
name = "everforest";
src = pkgs.fetchFromGitHub {
owner = "neanias";
repo = "everforest-nvim";
rev = "135cc21";
hash = "sha256-X+GaH76afaWmszGuLYf9VHP134jvmUCVSB7C7aiPSOs=";
};
})
];
# https://github.com/neanias/everforest-nvim?tab=readme-ov-file#overriding-highlight-groups
# https://github.com/neanias/everforest-nvim/blob/main/lua/everforest/highlights.lua
extraConfigLua = ''
require('everforest').setup({
background = 'hard',
italics = true,
on_highlights = function(hl, palette)
hl.Comment = { fg = palette.aqua }
hl.SpecialComment = { fg = palette.aqua }
end,
})
vim.o.background = "light"
'';
colorscheme = "everforest";
}