{pkgs, ...}: {
extraPlugins = [
(pkgs.vimUtils.buildVimPlugin {
name = "hover";
src = pkgs.fetchFromGitHub {
owner = "lewis6991";
repo = "hover.nvim";
rev = "1a8282f";
hash = "sha256-P63RQFFJhabGSeSmaMz4YirNUgbuu01aWRHbTp1qjTY=";
};
nvimSkipModules = [
"hover.providers.fold_preview"
];
})
];
extraConfigLua = ''
require('hover').setup({
init = function()
require('hover.providers.lsp')
end,
title = false,
mouse_providers = nil,
})
'';
keymaps = [
{
action = "<cmd>lua require('hover').hover()<CR>";
key = "K";
}
];
}