{
config,
lib,
pkgs,
...
}: let
cfg = config.roles.gaming;
in {
imports = [
./lutris.nix
./steam.nix
];
options.roles.gaming = {
enable = lib.mkEnableOption "gaming utilities";
lutris.enable = lib.mkEnableOption "Lutris";
steam.enable = lib.mkEnableOption "Steam";
};
config = lib.mkIf cfg.enable {
programs.gamemode = {
enable = true;
};
environment.systemPackages = with pkgs; [
gamescope
protontricks
gnome.zenity
];
hm = {
programs.mangohud = {
enable = true;
enableSessionWide = false;
settings = {
fps_limit = "60,90,120,200";
time = true;
gpu_stats = true;
gpu_temp = true;
gpu_text = "GPU";
cpu_stats = true;
cpu_temp = true;
cpu_text = "CPU";
vram = true;
ram = true;
fps = true;
frametime = true;
frame_timing = true;
show_fps_limit = true;
};
};
};
};
}