{
inputs,
lib,
pkgs,
...
}: {
imports = [
./hardware-configuration.nix
];
boot.initrd.postDeviceCommands = lib.mkAfter ''
zfs rollback -r zpool/root@blank
'';
sops.defaultSopsFile = ../../../secrets/alice/secrets.yaml;
sops.gnupg.sshKeyPaths = ["/persist/etc/ssh/ssh_host_rsa_key"];
sops.age.sshKeyPaths = ["/persist/etc/ssh/ssh_host_ed25519_key"];
networking.hostId = "bc56f04f";
networking.networkmanager.enable = true;
time.timeZone = "Europe/Helsinki";
i18n.defaultLocale = "en_US.UTF-8";
services.xserver.xkb.layout = "us";
environment.systemPackages = with pkgs; [
inputs.nvim-flake.packages.x86_64-linux.nvim
wget
font-awesome
liberation_ttf
(nerdfonts.override {
fonts = ["FiraCode" "VictorMono"];
})
];
environment.persistence."/persist" = {
hideMounts = true;
directories = [
"/etc/nixos"
"/etc/ssh"
"/var/lib/tailscale"
];
};
services.openssh.enable = true;
services.pcscd.enable = true;
programs.gnupg.agent.enable = true;
system.stateVersion = "24.05";
}