{
config,
lib,
pkgs,
modulesPath,
...
}: {
imports = [
(modulesPath + "/installer/scan/not-detected.nix")
];
boot.loader.systemd-boot.enable = true;
boot.loader.systemd-boot.configurationLimit = 9;
boot.loader.efi.canTouchEfiVariables = true;
boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "ahci" "usb_storage" "sd_mod"];
boot.initrd.kernelModules = ["zfs"];
boot.kernelModules = ["kvm-amd"];
boot.extraModulePackages = [];
boot.supportedFilesystems = ["zfs"];
fileSystems."/" = {
device = "zpool/root";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/home" = {
device = "zpool/home";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/nix" = {
device = "zpool/nix";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/persist" = {
device = "zpool/persist";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/3DA8-297C";
fsType = "vfat";
options = ["fmask=0022" "dmask=0022"];
};
swapDevices = [];
networking.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}