{
config,
lib,
...
}: let
cfg = config.roles.base;
in {
options.roles.base = {
root = lib.mkOption {
type = lib.types.submodule {
options = {
hashedPasswordFile = lib.mkOption {
type = lib.types.path;
};
};
};
};
};
config = {
users = {
mutableUsers = false;
users.root.hashedPasswordFile = cfg.root.hashedPasswordFile;
};
};
}