{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
flake-parts = {
url = "github:hercules-ci/flake-parts";
inputs.nixpkgs-lib.follows = "nixpkgs";
};
pre-commit-hooks = {
url = "github:cachix/git-hooks.nix";
inputs.nixpkgs.follows = "nixpkgs";
};
rust-overlay = {
url = "github:oxalica/rust-overlay";
inputs.nixpkgs.follows = "nixpkgs";
};
};
outputs = inputs @ {
self,
nixpkgs,
flake-parts,
pre-commit-hooks,
rust-overlay,
...
}:
flake-parts.lib.mkFlake {inherit inputs;} {
systems = ["x86_64-linux"];
perSystem = {
config,
lib,
pkgs,
system,
...
}: let
toolchain = pkgs.rust-bin.fromRustupToolchainFile ./rust-toolchain.toml;
libs = [];
in {
_module.args.pkgs = import inputs.nixpkgs {
inherit system;
overlays = [inputs.rust-overlay.overlays.default];
};
checks.pre-commit-check = pre-commit-hooks.lib.${system}.run {
src = ./.;
hooks = {
# Nix formatting
alejandra.enable = true;
# Toml formatting
taplo.enable = true;
# Rust formatting and linting
rustfmt = {
enable = true;
packageOverrides = {
cargo = toolchain;
rustfmt = toolchain;
};
};
clippy = {
enable = true;
packageOverrides = {
cargo = toolchain;
clippy = toolchain;
};
settings = {
denyWarnings = true;
};
};
# Spell checking
typos.enable = true;
};
};
devShells.default = pkgs.mkShell {
buildInputs = with pkgs;
[
just
go
protobuf
protoc-gen-go
protoc-gen-go-grpc
mold
clang
]
++ libs
++ [
toolchain
self.checks.${system}.pre-commit-check.enabledPackages
];
LD_LIBRARY_PATH = lib.makeLibraryPath libs;
shellHook = ''
${self.checks.${system}.pre-commit-check.shellHook}
'';
};
};
};
}